Get in touch
Back
Downtime

Service Unavailable

Started 24 Feb at 11:46am EST, resolved 24 Feb at 12:25pm EST.

ClassTag Website ClassTag Connect Services
Resolved

Our service providers are recovering the services. We are back online.

Posted 24 Feb at 12:25pm EST.
Created

The system we rely on to provide our services appears to be down. We will provide additional information as soon as possible.

Posted 24 Feb at 11:46am EST.